Wiring the Samurai distributor in LJ80

Links to articles to repair/upgrade your L series Suzuki

Moderator: Smuz

Post Reply
bluesilver
Dreams of LJs all day
Dreams of LJs all day
Posts: 12
Joined: Fri Aug 18, 2017 3:39 pm
Location: Australia

Wiring the Samurai distributor in LJ80

Post by bluesilver » Wed Jun 13, 2018 6:41 pm

Hi, this is an old topic to bring back up again, but i am hoping someone might be able to help me out a little here,
I am doing the Distributor swap, Putting a Samurai distributor in a LJ80
viewtopic.php?f=53&t=7720

I am kind of having some troble working through the wiring setup for some reason and was hoping someone can set me right.
Basically this is what i have:
The Samurai distributor has a blue wire with a fork / ring style connector, and a brown wire that splits into to brown wires with plug style ends on them

On the LJ80 distributor, i have a pink wire coming from the wiring harness that goes into the male spade lug on the distributor, and the ballast has a blue wire with a fork / ringed connector that bolts onto the side of the distributor.

Now this is where i got lost in finding out where each wire is suppose to go exactly.

With the Samurai distributor in place, Can anyone help me out by telling me where the wire that i have listed are suppose to be going as it seams a little different from what i have read in the link viewtopic.php?f=53&t=7720

Sorry if it is a basic question, just got a little confused as i seam to be missing a few steps at least for me anyway.
It would be greatly appreciated.
Cheers.
User avatar
stevec
The Parts Dude!
The Parts Dude!
Posts: 7542
Joined: Thu Jun 12, 2003 9:26 am
Location: Seattle WA area

Re: Wiring the Samurai distributor in LJ80

Post by stevec » Thu Jun 14, 2018 9:56 am

From your description it sounds like you have the same setup, except the pink wire may be a different color. Can you post pics of your set up?
The only difference between an ordeal and an adventure is your attitude
Banzai
LJ Enthusiast
LJ Enthusiast
Posts: 155
Joined: Sat May 14, 2011 12:20 pm
Location: Saint John, New Brunswick

Re: Wiring the Samurai distributor in LJ80

Post by Banzai » Tue Nov 13, 2018 5:48 pm

BlueSilver - I'm in the middle of this swap right now, with a new distributor I bought off eBay. It has the same brown wire with 2 plugs, and a blue wire with forked terminal.

The only way I can get it to fire is to attach it to the "-" of the primary windings on the coil, instead of the end of a ballast resistor as mentioned in previous write up. Brown wires connects as directed in other write ups.

I've only gone on a 5 minute drive with it so far. Didn't catch fire, or blow up. Not sure why it wouldn't work when connected as suggested.

I'll try to check back in, once I take it for a few drives.

Ron
Post Reply